DirectLine – New Web Browser requirements

Effective Date:  January 31st, 2021 9:00am EST

Megamation will be upgrading the DirectLine application delivery controller on January 31st, 2021. All Direct Line users connect to this device via https://login.megamation.com to launch the DirectLine application.

This device is responsible for encrypting all web traffic into and out of our server farm. The upgrade is required to ensure we continue to provide a safe and secure connection to DirectLine with support for the latest security protocols.

The following changes will also take effect on this date:

–          Transport Layer Security (TLS) web protocols TLS 1.1 will not longer be supported

–          Transport Layer Security (TLS) web protocols 1.2 & 1.3 will be supported

The industry is working to depreciate support for TLS 1.1. Google, Microsoft, Apple and Mozilla have announced their browsers will no longer support TLS 1.1 as of March 2020.

New Windows Browser Requirements (effective January 31st, 2021).  All the browser versions listed below are currently supported and we recommend updating any non-supported browsers now.

Internet Explorer:

  1. Internet Explorer versions 11 will be fully supported.  Internet Explorer version 11 is the only version of Internet Explorer still supported by Microsoft without an Extended Support Agreement (ESU).
  2. Internet Explorer 9 & 10 will continue to work but will require TSL1.2 to be enabled.   By default, TLS1.2 is not enabled.   We recommend you install either the latest version of Internet Explorer or another supported browser.
  3. Enterprise mode & Internet Explorer version 11:  Internet Explorer 11 Enterprise mode allows the browser to run in backward compatibility mode.  DirectLine (https://login.megamation.com)  must be removed from the Enterprise Mode Site List.  DirectLine currently does not require backward compatibility.  Enterprise mode will not be supported after January 31/2021.
    Relevant Links:
    https://docs.microsoft.com/en-us/internet-explorer/ie11-deploy-guide/tips-and-tricks-to-manage-ie-compatibility
    https://docs.microsoft.com/en-us/internet-explorer/ie11-deploy-guide/using-enterprise-mode

Mozilla Firefox:

Version 45 and later.  Preferred version is 65.0.2 (64-bit) or higher.

Chrome:

Version 60 and later.  Preferred version is 0.3626.121 (64-bit) or higher.

Microsoft Edge:

All versions

New MAC Browser Requirements:

  1. Mozilla Firefox: version 45 and later.
  2. Safari: version 10.1.1 and later.

 

The new browser requirements do not apply to the DirectLine mobile application (https://m.megamation.com) and the DirectLine work order entry page (https://dlweb.megamation.com). However, It is strongly recommended that browsers be updated for these applications as well. We will be scheduling a future upgrade for these platforms to only support TLS1.2 or higher.